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About this guide

Introduction
This guide provides instructions on backing up and restoring appliance level settings and 
sites for Ensim® WEBppliance™ Pro for Windows® 2000 and Ensim WEBppliance Pro for 
Windows 2003.

Appliance Administrators can use the backup and restore utilities to periodically back up 
appliance settings and site data of their WEBppliance Pro server and restore these on the same 
server or a new WEBppliance Pro server. This may be needed when moving sites to a new 
WEBppliance Pro server or when recovering from a crashed hard disk or the accidental 
deletion of a site from the WEBppliance Pro server.

The backup and restore utilities cannot be used to move sites from a 
WEBppliance Pro server to another WEBppliance Pro server with existing sites. 
Additionally, data backed up from one version of WEBppliance Pro cannot be 
restored to another version of WEBppliance Pro.

Intended audience
This guide is designed to aid ISPs and Appliance Administrators using Ensim WEBppliance 
Pro for Windows 2000 and Ensim WEBppliance Pro for Windows 2003 in the planning and 
implementation of the backup and restore process.

We recommend that you read the entire document and understand all 
instructions before you start the backup and restore process. The backup and 
restore utilities work with "live" data, so you must ensure that you fulfill all 
requirements and understand the limitations of the backup and restore process. 
For an overview of the backup and restore process and a list of known limitations, 
see Chapter 1, “Preparing for the backup”.

Printer-friendly version (for HTML documents)
This document is presented in HTML and PDF formats. If you are viewing this document in 
HTML format and want to print it in a book style with numbered pages, access the Adobe® 
PDF version. 
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Required skills
To use this guide, you must have some or all of the following skills:

• Experience using the Microsoft® Windows 2000 and Windows 2003 operating system

• Experience with networking applications

• Experience using Ensim WEBppliance Pro for Windows

Related documentation
For information about installation-related information and known issues, refer to the 
following documents on the Ensim Web site at http://www.ensim.com/support/wwp/
index.html.

• Ensim WEBppliance Pro for Windows 2000 Release Notes

• Ensim WEBppliance Pro for Windows 2000 Installation Guide

• Ensim WEBppliance Pro for Windows 2003 Release Notes

• Ensim WEBppliance Pro for Windows 2003 Installation Guide

Additional resources
For help with product functions, refer to the WEBppliance Pro for Windows online Help. You 
can access the online Help from the WEBppliance Pro interface.

To open the online Help for a particular level:

1 Log on to WEBppliance Pro at the respective level; for example, log on as the Appliance 
Administrator.

2 Click Help on the left navigation bar of the WEBppliance Pro interface.

Document conventions
Throughout this guide, specific fonts are used to identify computer input, output, and 
interface elements. Table 1 lists the typographic conventions used in this guide.

Table 1. Typographic conventions

Appearance of text How it is used

Narrow bold text (sans 
serif font)

Used for button names, column names, field names, 
file names, keystrokes, menu items, and path names.

Example: From the File menu, choose Delete, then click OK.

Bold, italic text (serif font) Used for information you type. 

Example: Type cd <directory name> on the command line.

Courier (typewriter-style) 
font

Used for system messages and screen text.

Example: The following message is displayed:

The server has been added.

http://www.ensim.com/support/wwp/index.html
http://www.ensim.com/support/wwp/index.html
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Key information is sometimes displayed using special headings and formats to make it stand 
out from regular text. The following special headings are used in this guide:

Information to help you perform procedures

Supplemental information about tasks or concepts

Supplemental information that is more important than a note

Warnings about potential damage to data or systems

Feedback and support
To take advantage of Ensim’s support services or to find additional product documentation, 
visit the Ensim support site, http://support.ensim.com.

To log on to Ensim online support, go to https://onlinesupport.ensim.com. 

To provide feedback about Ensim products or documentation, please use the feedback form 
at http://www.ensim.com/support/feedback.asp.

https://onlinesupport.ensim.com
http://www.ensim.com/support/feedback.asp
http://support.ensim.com
http://support.ensim.com
http://www.ensim.com/support/feedback.asp
http://support.ensim.com
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CHAPTER 1

Preparing for the backup

Introduction
This chapter describes the preparation required before you start to back up or restore data. It 
also provides an overview of the backup and restore process and describes the known 
limitations of the backup and restore process.

Topics in this chapter include:

• “About the backup process” on page 1-1

• “What is backed up” on page 1-2

• “What is not backed up” on page 1-3

• “Effects of restoring” on page 1-3

• “Known issues of backup and restore” on page 1-4

About the backup process
The Appliance Administrator can choose to back up either appliance settings or site data. The 
backup can be used to:

• Restore the WEBppliance Pro settings in the event of a system failure

• Restore reseller data and site data for sites owned by a reseller

• Restore all sites or an individual site

You can back up a single site and restore it; however, it is not possible to back up 
and restore a single reseller or any other individual appliance settings. 
Additionally, it is not possible to restore data backed up from one version of 
WEBppliance Pro to another version.

You can restore the appliance settings and site data to:

• A new server

To restore appliance settings or site data to a new server, install Windows 2000 or 
Windows 2003 and WEBppliance Pro on the new server and ensure that the host name 
and IP address of the new server is the same as the server that was backed up.
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• The server that was backed up

The appliance settings cannot be restored directly to an existing server. You must first 
format the server, reinstall Windows 2000 or Windows 2003 and WEBppliance Pro, ensure 
that the host name and IP address of the server is the same before it was backed up, and 
then restore the appliance settings.

To restore a single site or multiple sites, you must remove the site or sites from 
WEBppliance Pro before restoring the site data.

The backup and restore process uses two Command Line Interface utilities. The Export.vbs 
utility is used to back up the appliance settings and site data, while the ImportDomain.pyc 
utility is used to restore the appliance settings and site data.

Disk space requirement
Before backing up data, ensure that your WEBppliance Pro server has sufficient disk space 
available for storing the backup file. This must be at least twice the size of the site data.

What is backed up
The backup process creates a file in ZIP format and stores appliance and site level data.

Appliance level
The appliance level backup includes:

• SSL server key, certificate, and certificate request files

• Navigation bar customizations, logos, and banners

• Default Web site configuration

• Web site defaults used as the template to create Web sites

• Data Source Names (DSNs) created by the Appliance Administrator

• IP addresses from the Appliance Administrator's IP pool

• Resellers created by the Appliance Administrator and their settings

• Reseller Plans created by the Appliance Administrator

• Service Plans created by the Appliance Administrator

• Service Plans created by resellers

• Navigation bar customizations, logos, and banners for resellers

Site level
The site level backup includes:

• Available services

• Web server and FTP server configuration

• File system of the sites

• All email users of the site and their mail configuration

• Web and FTP logs

• Analog usage data

• Urchin usage data
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• All email messages of all users stored on the server

Email users and email messages are not backed up on an Ensim WEBppliance 
Pro for Windows 2003 server. Additionally, on an Ensim WEBppliance Pro for 
Windows 2000 server, email users and email messages are not backed up for mail 
servers other than MailMax®.

• DNS records added for the zones belonging to the site

• Data Source Names (DSNs) created by the Site Administrator

• Virtual directory settings

• Host headers

What is not backed up
The backup does not include:

• Zones added explicitly by the Appliance Administrator

• Domain level SSL certificates, keys, and certificate requests

For information and instructions about backing up an SSL certificate, see the Microsoft 
Knowledge Base Article 232136 available at http://support.microsoft.com/
default.aspx?scid=kb;EN-US;232136. 

For information and instructions about restoring an SSL certificate, see the Microsoft 
Knowledge Base Article 232137 available at http://support.microsoft.com/
default.aspx?scid=kb;EN-US;232137.

The preceding Knowledge Base articles are also applicable to Internet 
Information Services (IIS) 6.0.

• Site Administrator password

• Customizations implemented without using the WEBppliance Pro interface; for example, 
skins

• Additional Appliance Administrators created other than the default Appliance 
Administrator

• Databases associated with the Appliance Administrator level Data Source Names (DSNs) 

You have to manually copy the databases after restoring the site data.

Effects of restoring
Once the restore process is complete, Site Administrators will see changes specific to their 
level.

At the site level
After restoring a site:

• The LogFiles directory in the site file system may contain new directories in addition to 
the existing directories.

http://support.microsoft.com/default.aspx?scid=kb;EN-US;232136
http://support.microsoft.com/default.aspx?scid=kb;EN-US;232136
http://support.microsoft.com/default.aspx?scid=kb;EN-US;232137
http://support.microsoft.com/default.aspx?scid=kb;EN-US;232137
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• The FTP port number for a name-based site (used to access the site through FTP) will 
change to a new number.

To view the new FTP port number:

a Log on to WEBppliance Pro as the Site Administrator.

b In the left navigation bar, click SITE INFORMATION. The Configuration page 
displays.

c In the Configuration page, the new FTP port number is displayed in the Domain/Site 
URLs area next to the ftp: label. For example, in the URL ftp://somesite.org:10004, 
10004 is the FTP port number.

• The Site Administrator password will change to a random number. 

This password is also applicable to Microsoft FrontPage® and Web Mail. The new 
password is stored in a file called PasswordList.txt located on C:\ (or relative root 
directory of the location specified for backup) on the WEBppliance Pro server. The file 
contains the Site Administrator login name and the corresponding new password. For 
example,

Username New Password

sk8 348025

kingkong 498210

If the Site Administrator name and password occurs more than once in the 
password file, use the last entry. Multiple entries may display if the site has been 
restored more than once.

Known issues of backup and restore
This section describes the known issues of the backup and restore process.

• If a site to be backed up exceeds its disk quota, it may be in a suspended state after 
restoring. You must enable the site from within the WEBppliance Pro interface after 
restoring it. For instructions about enabling a site from WEBppliance Pro, see the 
WEBppliance Pro online Help.

• After restoring, the NS records on the restored WEBppliance Pro server may contain two 
periods (..). You must edit the NS record to remove the extra period.

To edit the NS records:

a Connect to the WEBppliance Pro server and log on as the Appliance Administrator.

b Click Services > ISC BIND configure icon > Zone name > Edit icon.

• After restoring a site, the MS SQL ODBC option will reflect the setting of the ODBC 
option.

To change the MS SQL ODBC option:

a Log on to the WEBppliance Pro server as the Appliance Administrator.

b In the left navigation bar, click SITE MANAGER.

c Locate the site to be modified and click the Configure Site icon in the Actions 
column. The Edit Site form displays.

d In the Site Options area, select or clear the MS SQL ODBC check box.
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CHAPTER 2

Backing up and restoring appliance
settings and sites

Introduction
This chapter describes how to back up and restore appliance settings and site data.

Topics in this chapter include:

• “Installing the backup and restore utilities” on page 2-1

• “Backing up appliance settings and site data” on page 2-1

• “Restoring appliance settings and site data” on page 2-2

• “Command syntax” on page 2-2

• “Post-restore tasks” on page 2-6

Installing the backup and restore utilities
Before you start, you must copy the Export.vbs and the ImportDomain.pyc files to the 
WEBppliance Pro server. To obtain the backup and restore utilities, please contact Ensim 
Support; for support options, see “Feedback and support” on page v.

Backing up appliance settings and site data
After you copy the Export.vbs file to the WEBppliance Pro server, use it to back up appliance 
settings and site data.

Procedure: To back up appliance settings and site data:

1 Connect to the WEBppliance Pro server using the console or terminal services and log on 
as the administrator.

2 Open a command prompt window (Click Start > Run > type cmd > OK), and change to 
the directory where you have copied the Export.vbs file.

3 Stop the virtualhosting service. To do this, at the command prompt, type:

net stop virtualhosting
4 Back up the required data using the Export.vbs file. For command usage and syntax, see 

“Backing up data using Export.vbs” on page 2-2.

5 Start the virtualhosting service after backing up the required data. To do this, at the 
command prompt, type:

net start virtualhosting
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Restoring appliance settings and site data
After you copy the ImportDomain.pyc file to the WEBppliance Pro server, use it to restore the 
backed up data.

Procedure: To restore appliance settings and site data:

1 Connect to the WEBppliance Pro server using the console or terminal services and log on 
as the administrator.

2 Open a command prompt window (Click Start > Run > type cmd > OK), and change to 
the directory where you have copied the ImportDomain.pyc file.

3 Stop the virtualhosting service. To do this, at the command prompt, type:

net stop virtualhosting
4 Restore the required data using the ImportDomain.pyc file. For command usage and 

syntax, see “Restoring data using ImportDomain.pyc” on page 2-4.

5 Start the virtualhosting service after restoring the required data. To do this, at the 
command prompt, type:

net start virtualhosting

Command syntax
The backup and restore utilities must be run from the Command Line Interface. The syntax for 
these commands is described in the following sections with a few examples. Typing the 
command without specifying any option displays the command usage.

Backing up data using Export.vbs
Use the Export.vbs utility to back up appliance settings and site data from WEBppliance Pro.

To back up data, use the command:

cscript //nologo Export.vbs [--appliance/--domain=all/<domain_list>] 
[--zippath=<zipfile_path>] [--temppath=<tempfile_path>]

The Export.vbs command uses the following options. Unless mentioned otherwise, options 
are not mandatory.

appliance: Use this option to back up appliance settings.

domain=all/<domain_list>: Use this option to back up site related settings and files. Use all to 
back up all sites or specify the sites you want to back up in a comma separated list. 

You can use either the appliance or domain option, but not both at the same 
time.

zippath=<zipfile_path>: This option is mandatory and the specified path should exist. The 
Export.vbs command will create ZIP files at the specified location with the name 
Appliance.zip for appliance settings and Domains.zip for site data. The names of these files 
cannot be changed. If you do not mention a path, the ZIP file is created in C:\.
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As the name of the ZIP file cannot be changed, if you run the command more 
than once at the same location, the previously created ZIP file will be overwritten 
with the new file. In case you want to create multiple backup sets, rename the 
existing file and create a new backup file. Renaming the backup file does not 
affect the restore process.

temppath=<tempfile_path>: This is the path where temporary files will be created. If you do 
not specify this path, the system path for temporary files is used.

Example: To back up only appliance settings without specifying a directory for 
temporary files, type the command:

cscript Export.vbs --appliance --zippath=c:\test

This command backs up appliance settings to the file Appliance.zip in 
the directory c:\test. The directory specified in the system path is used 
for storing temporary files.

Example: To back up only appliance settings by specifying a directory for 
temporary files, type the command:

cscript Export.vbs --appliance --zippath=c:\backup 
--temppath=c:\temp

This command backs up appliance settings to the file Appliance.zip in 
the directory c:\backup and stores temporary files in the directory 
c:\temp.

Example: To back up only site data for a single site, type the command:

cscript Export.vbs --domain=mysite1.com --zippath=c:\test1

This command backs up site information for the site mysite1.com to the 
file Domains.zip in the directory c:\test1. The directory specified in the 
system path is used for storing temporary files.

Example: To back up only site data for multiple sites, type the command:

cscript Export.vbs --
domain=domain1.com,domain2.com,domain3.org 
--zippath=c:\backedupdata --temppath=c:\temp

This command backs up site data for the sites domain1.com, 
domain2.com, and domain3.org to the file Domains.zip in the directory 
c:\backedupdata and stores temporary files in the directory c:\temp.
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Example: To back up site data for all sites, type the command:

cscript Export.vbs --domain=all --zippath=c:\test1

This command backs up site information for all sites to the file 
Domains.zip in the directory c:\test1. The directory specified in the 
system path is used for storing temporary files.

Diagnostics

If an error occurs, the command line displays the appropriate message. If the data from some 
sites (but not all) is successfully backed up, the errors and warnings are recorded in the system 
event log.

To access the system event log: 

1 Connect to the WEBppliance Pro server using the console or terminal services and log on 
as the administrator.

2 Click Start > Programs > Administrative Tools > Event Viewer.
3 Click Windows Webppliance in the left pane. 

4 Double click the error or warning item to view more information about it.

Restoring data using ImportDomain.pyc
Use the ImportDomain.pyc utility to restore appliance settings and site data backed up from 
WEBppliance Pro.

To restore appliance settings and site data, use the command:

python ImportDomain.pyc --zippath=<zipfile_path> --temppath=<tempfile_path>

The ImportDomain.pyc command uses the following options. Unless mentioned, options are 
not mandatory.

zippath=<zipfile_path>: This option is mandatory and is the name of the ZIP file to be 
extracted with the full path (for appliance settings the file name is Appliance.zip and for site 
data it is Domains.zip). The path should exist.

temppath=<tempfile_path>: This is the path where temporary files will be created. If you do 
not specify this path, the system path for temporary files is used.

Example: To restore appliance settings without specifying a directory for 
temporary files, type the command:

python ImportDomain.pyc --zippath=c:\test\Appliance.zip

This command restores appliance settings from the file Appliance.zip 
located in the directory c:\test. The directory specified in the system path 
is used for storing temporary files.
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Example: To restore appliance settings by specifying a directory for temporary files, 
type the command:

python ImportDomain.pyc --zippath=c:\backedupdata\Appliance.zip 
--temppath=c:\temp

This command restores appliance settings from the file Appliance.zip 
located in the directory c:\backedupdata and stores temporary files in 
the directory c:\temp.

Example: To restore site data without specifying a directory for temporary files, 
type the command:

python ImportDomain.pyc --zippath=c:\test1\Domains.zip

This command restores site data for the sites contained in the file 
Domains.zip located in the directory c:\test1. The directory specified in 
the system path is used for storing temporary files.

Example: To restore site data by specifying a directory for temporary files, type the 
command:

python ImportDomain.pyc --zippath=c:\backedupdata\Domains.zip 
--temppath=c:\temp

This command restores site data for the sites contained in the file 
Domains.zip located in the directory c:\backedupdata and stores 
temporary files in the directory c:\temp.

Diagnostics

If an error occurs while restoring the data, the command displays messages on the command 
prompt. If the restore was successful, but errors occurred while restoring the site data, the 
errors and warnings are recorded in the system event log. For sites that fail during the restore 
process, roll-back happens automatically.

To access the system event log:

1 Connect to the WEBppliance Pro server using the console or terminal services and log on 
as the administrator.

2 Click Start > Programs > Administrative Tools > Event Viewer.
3 Click Windows Webppliance in the left pane. 

4 Double click the error or warning item to view more information about it.
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Post-restore tasks
After restoring appliance settings or site data, you may have to complete certain tasks to 
restore the appliance settings or site configuration to the pre-backup state. This section 
describes these tasks for the appliance and site level.

Appliance level
After restoring appliance settings, reapply custom IIS mappings for each domain.

To apply IIS mappings:

1 Connect to the WEBppliance Pro server using the console or terminal services and log on 
as the administrator.

2 Click Start > Programs > Administrative Tools > Internet Information Services (IIS) 
Manager. The IIS Manager window displays.

3 Add the desired IIS mappings for each domain using menu options in the IIS Manager 
window. For instructions, see the IIS Help by clicking Help in the IIS Manager menu.

Site level
After restoring site data:

• Disable Microsoft FrontPage authoring for sites that had Microsoft FrontPage authoring 
disabled before they were backed up.

To disable FrontPage authoring for a site:

a Log on to the WEBppliance Pro server as the Appliance Administrator.

b In the left navigation bar, click SITE MANAGER.

c Locate the site to be modified and click the Configure Site icon in the Actions 
column. The Edit Site form displays.

d In the Site Options area, clear the Microsoft FrontPage Server Extensions 2002 
check box.

• Reapply custom permissions for site files and directories from the Site Administrator 
interface. You may have to ask the Site Administrator to perform this task if you are not 
aware of the custom permissions set for a particular site.

To apply custom permissions to files and directories:

a Log on to the WEBppliance Pro server as the Site Administrator. If you are applying 
custom permissions yourself, use the auto-logon feature of WEBppliance Pro to log on 
as the Site Administrator.

b In the left navigation bar, click FILE MANAGER.

c Select the check box next to the files and directories.

d Select the Read or Write check box or both as desired.

e Click Set Permission.

For more information, see the Site Administrator online Help by clicking Help in the left 
navigation bar.

• Enable .NET for sites that had .NET enabled before they were backed up (only for Ensim 
WEBppliance Pro for Windows 2000). For instructions about enabling .NET, refer to Ensim 
WEBppliance for Windows .NET Guide. You can access the latest version of this document at 
http://www.ensim.com/support/wwp/index.html.

http://www.ensim.com/support/wwp/index.html
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CHAPTER 3

Troubleshooting

Introduction
This chapter describes the potential problems that you may encounter during the backup and 
restore process and provides information on how to resolve them. If you still have problems, 
please contact Ensim Support. For information about support options, see “Feedback and 
support” on page v.

Topics in this chapter include:

• “Troubleshooting backup errors” on page 3-1

• “Troubleshooting restore errors” on page 3-1

Troubleshooting backup errors
If an error occurs when site information is extracted to a ZIP file, the error message is 
displayed on the command prompt. Depending on the exact error encountered, try and rectify 
the problem and repeat the backup process for sites with problems.

Troubleshooting restore errors
When restoring site data, the system event log records whether a site has been successfully 
restored or not. If the ImportDomain command fails to restore the site information 
successfully, it automatically starts the roll-back process and removes the partially restored 
data. You see the appropriate message on the command line or in the system event log. In case 
of a catastrophic failure before the roll-back process is completed (such as a power shut-off), 
there is no record of the site in the system event log. In this case you need to delete the site 
data from the WEBppliance Pro server and restore the site again.

Depending on the extent to which the site information has been restored, you may need to 
delete:

• The site file system by deleting the site directory

• Web and FTP entries in Internet Information Server (IIS) by using the Internet Services 
Manager

• DNS zones by using the WEBppliance Pro interface

• MySQL databases by running the script cscript delmysqldb.vbs <siteadmin_name> 
<database_name> located in:

❑ C:\Program Files\Ensim\Webppliance for the Standalone version of WEBppliance 
Pro

❑ C:\Webgui for the Ensim ServerXchange® version of WEBppliance Pro
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To access the system event log: 

1 Connect to the WEBppliance Pro server using the console or terminal services and log on 
as the administrator.

2 Click Start > Programs > Administrative Tools > Event Viewer.
3 Click Windows Webppliance in the left pane. 

4 Double click the error or warning item to view more information about it.

Possible errors and their solutions
• You cannot browse the home page of new sites added after restoring data on the 

WEBppliance Pro server. The following error is displayed: "The filename, 
directory name, or volume label syntax is incorrect."

Cause: This happens if the default Service Plan or one of the restored Service Plans used 
to create new sites contains quotes ( " ) in the list of default documents.

Solution: Remove quotes from the list of default documents for the Service Plans and also 
for the newly created sites.

For Service Plans:

To remove quotes from the list of default documents for Service Plans:

a Connect to the WEBppliance Pro server and log on as the Appliance Administrator. 

b In the left navigation bar, click Site Manager. 
c In the Sites Manager menu, click View Plans. 

d In the list of plans, locate the plan and in the Action column, click the Edit icon. 

e In the Documents area, in the Default Document text box, remove the quotes, if 
present, from the list of default documents.

For example, the list may appear as: 
"Default.htm,Default.html,Default.asp,index.htm,index.html,index.asp". 
Remove the starting and closing quotes from this string.

For newly added sites:

To remove the quotes from the list of default documents for all newly added sites whose 
home pages cannot be browsed:

a Connect to the WEBppliance Pro server and log on as the Appliance Administrator. 

b In the left navigation bar, click Site Manager. 
c Locate the site to be modified and in the Actions column, click the Edit icon. 

d In the Documents area, in the Default Document text box, remove the quotes, if 
present, from the list of default documents. 

For example, the list may appear as: 
"Default.htm,Default.html,Default.asp,index.htm,index.html,index.asp". 
Remove the starting and closing quotes from this string.

• After restoring a site, it remains in suspended state.

Cause: This happens if the restored site has exceeded the disk quota on the WEBppliance 
Pro server where it has been restored.

Solution: Enable the site on the WEBppliance Pro server through the WEBppliance Pro 
interface. Log on as the Appliance Administrator and click the Site Manager > Start icon.
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• Database files (for example, .mdb) associated with Appliance Administrator Data Source 
Names (DSNs) are not restored.

Solution: Restore the database files manually by copying them from their original 
location on the WEBppliance Pro server (from where they were backed up). Ensure that 
the directory structure of these database files is the same as the server from which they 
were copied.

• NS records for a restored site contain double periods (..).

Solution: Edit the NS record for the restored site and remove the extra period. 

To edit the NS records: 

a Connect to the WEBppliance Pro server and log on as the Appliance Administrator.

b Click Services > ISC BIND configure icon > Zone name > Edit icon.
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